discuss@lists.openscad.org

OpenSCAD general discussion

View all threads

Odd thrown together

RP
Ronaldo Persiano
Thu, Apr 1, 2021 1:30 AM

In the last OpenSCAD release, draw a cube, select View/Thrown together and
click the cube with the right button. Click again. The cube goes red and
the only way I am able to recover is by View/Preview. Also, View/Wireframe
and View/Surfaces don't work.

In the last OpenSCAD release, draw a cube, select View/Thrown together and click the cube with the right button. Click again. The cube goes red and the only way I am able to recover is by View/Preview. Also, View/Wireframe and View/Surfaces don't work.
NH
nop head
Thu, Apr 1, 2021 12:17 PM

Even stranger for me, I just get a black window. Looks like the right click
to see the code that makes the cube is going wrong.

[image: image.png]

On Thu, 1 Apr 2021 at 02:30, Ronaldo Persiano rcmpersiano@gmail.com wrote:

In the last OpenSCAD release, draw a cube, select View/Thrown together and
click the cube with the right button. Click again. The cube goes red and
the only way I am able to recover is by View/Preview. Also, View/Wireframe
and View/Surfaces don't work.


OpenSCAD mailing list
To unsubscribe send an email to discuss-leave@lists.openscad.org

Even stranger for me, I just get a black window. Looks like the right click to see the code that makes the cube is going wrong. [image: image.png] On Thu, 1 Apr 2021 at 02:30, Ronaldo Persiano <rcmpersiano@gmail.com> wrote: > In the last OpenSCAD release, draw a cube, select View/Thrown together and > click the cube with the right button. Click again. The cube goes red and > the only way I am able to recover is by View/Preview. Also, View/Wireframe > and View/Surfaces don't work. > _______________________________________________ > OpenSCAD mailing list > To unsubscribe send an email to discuss-leave@lists.openscad.org >
RP
Ronaldo Persiano
Thu, Apr 1, 2021 12:30 PM

Even stranger for me, I just get a black window. Looks like the right
click to see the code that makes the cube is going wrong.

Yes, sometimes I get a black object instead of red. Have you View All after
the black screen?

The bug has many manifestations and not always I am able to reproduce a
specific one. For instance, once I was unable to get the right colors back
even changing to View/Preview. Interestingly, in that case the
View/Wireframe and View/Surface worked despite the wrong colors. To get rid
of it I had to restart.

> > Even stranger for me, I just get a black window. Looks like the right > click to see the code that makes the cube is going wrong. > Yes, sometimes I get a black object instead of red. Have you View All after the black screen? The bug has many manifestations and not always I am able to reproduce a specific one. For instance, once I was unable to get the right colors back even changing to View/Preview. Interestingly, in that case the View/Wireframe and View/Surface worked despite the wrong colors. To get rid of it I had to restart.
NH
nop head
Thu, Apr 1, 2021 1:26 PM

I haven't got any menus but I can get the view menu with Alt+V but view all
is then Ctrl+Shift+V and that does not work.  I can arrow down to it and
select it but I still have an all black window.

I think this is a separate bug because I don't need to be in thrown
together mode. Just a right click on the cube with another Microsoft
Mouse that has switch bounce on the right button. It shows the one line
stack trace over an all black window and I haven't found a way to recover.

OpenSCAD 2021.03.24.ci7656 on Win7 / 64.

On Thu, 1 Apr 2021 at 13:30, Ronaldo Persiano rcmpersiano@gmail.com wrote:

Even stranger for me, I just get a black window. Looks like the right

click to see the code that makes the cube is going wrong.

Yes, sometimes I get a black object instead of red. Have you View All
after the black screen?

The bug has many manifestations and not always I am able to reproduce a
specific one. For instance, once I was unable to get the right colors back
even changing to View/Preview. Interestingly, in that case the
View/Wireframe and View/Surface worked despite the wrong colors. To get rid
of it I had to restart.


OpenSCAD mailing list
To unsubscribe send an email to discuss-leave@lists.openscad.org

I haven't got any menus but I can get the view menu with Alt+V but view all is then Ctrl+Shift+V and that does not work. I can arrow down to it and select it but I still have an all black window. I think this is a separate bug because I don't need to be in thrown together mode. Just a right click on the cube with another Microsoft Mouse that has switch bounce on the right button. It shows the one line stack trace over an all black window and I haven't found a way to recover. OpenSCAD 2021.03.24.ci7656 on Win7 / 64. On Thu, 1 Apr 2021 at 13:30, Ronaldo Persiano <rcmpersiano@gmail.com> wrote: > Even stranger for me, I just get a black window. Looks like the right >> click to see the code that makes the cube is going wrong. >> > > Yes, sometimes I get a black object instead of red. Have you View All > after the black screen? > > The bug has many manifestations and not always I am able to reproduce a > specific one. For instance, once I was unable to get the right colors back > even changing to View/Preview. Interestingly, in that case the > View/Wireframe and View/Surface worked despite the wrong colors. To get rid > of it I had to restart. > _______________________________________________ > OpenSCAD mailing list > To unsubscribe send an email to discuss-leave@lists.openscad.org >
NH
nop head
Thu, Apr 1, 2021 1:28 PM

To be clear, it isn't a black object filling the preview window, it is the
whole main window pane that goes black.

On Thu, 1 Apr 2021 at 14:26, nop head nop.head@gmail.com wrote:

I haven't got any menus but I can get the view menu with Alt+V but view
all is then Ctrl+Shift+V and that does not work.  I can arrow down to it
and select it but I still have an all black window.

I think this is a separate bug because I don't need to be in thrown
together mode. Just a right click on the cube with another Microsoft
Mouse that has switch bounce on the right button. It shows the one line
stack trace over an all black window and I haven't found a way to recover.

OpenSCAD 2021.03.24.ci7656 on Win7 / 64.

On Thu, 1 Apr 2021 at 13:30, Ronaldo Persiano rcmpersiano@gmail.com
wrote:

Even stranger for me, I just get a black window. Looks like the right

click to see the code that makes the cube is going wrong.

Yes, sometimes I get a black object instead of red. Have you View All
after the black screen?

The bug has many manifestations and not always I am able to reproduce a
specific one. For instance, once I was unable to get the right colors back
even changing to View/Preview. Interestingly, in that case the
View/Wireframe and View/Surface worked despite the wrong colors. To get rid
of it I had to restart.


OpenSCAD mailing list
To unsubscribe send an email to discuss-leave@lists.openscad.org

To be clear, it isn't a black object filling the preview window, it is the whole main window pane that goes black. On Thu, 1 Apr 2021 at 14:26, nop head <nop.head@gmail.com> wrote: > I haven't got any menus but I can get the view menu with Alt+V but view > all is then Ctrl+Shift+V and that does not work. I can arrow down to it > and select it but I still have an all black window. > > I think this is a separate bug because I don't need to be in thrown > together mode. Just a right click on the cube with another Microsoft > Mouse that has switch bounce on the right button. It shows the one line > stack trace over an all black window and I haven't found a way to recover. > > OpenSCAD 2021.03.24.ci7656 on Win7 / 64. > > On Thu, 1 Apr 2021 at 13:30, Ronaldo Persiano <rcmpersiano@gmail.com> > wrote: > >> Even stranger for me, I just get a black window. Looks like the right >>> click to see the code that makes the cube is going wrong. >>> >> >> Yes, sometimes I get a black object instead of red. Have you View All >> after the black screen? >> >> The bug has many manifestations and not always I am able to reproduce a >> specific one. For instance, once I was unable to get the right colors back >> even changing to View/Preview. Interestingly, in that case the >> View/Wireframe and View/Surface worked despite the wrong colors. To get rid >> of it I had to restart. >> _______________________________________________ >> OpenSCAD mailing list >> To unsubscribe send an email to discuss-leave@lists.openscad.org >> >
JW
Johannes Walcher
Thu, Apr 1, 2021 2:44 PM

This Black / Red thingi might be a side effect of the mouse selection,
triggered by the right click.
The selector is drawing into a separate background buffer. Unfortunately
I cannot reproduce this behaviour on master on my machine.

The ID of the object is encoded into the color, whereby object 1-255 are
encoded in different shades of red, 0 (black) is the background.

This might be a bug in the combination of thrown-together/selection, it
looks like the framebuffer selection is somehow broken.
I will look into this as soon as I can make room in my schedule!

On 01/04/2021 15.28, nop head wrote:

To be clear, it isn't a black object filling the preview window, it is
the whole main window pane that goes black.

On Thu, 1 Apr 2021 at 14:26, nop head <nop.head@gmail.com
mailto:nop.head@gmail.com> wrote:

 I haven't got any menus but I can get the view menu with Alt+V but
 view all is then Ctrl+Shift+V and that does not work.  I can arrow
 down to it and select it but I still have an all black window.

 I think this is a separate bug because I don't need to be in
 thrown together mode. Just a right click on the cube with another
 Microsoft Mouse that has switch bounce on the right button. It
 shows the one line stack trace over an all black window and I
 haven't found a way to recover.

 OpenSCAD 2021.03.24.ci7656 on Win7/ 64.


 On Thu, 1 Apr 2021 at 13:30, Ronaldo Persiano
 <rcmpersiano@gmail.com <mailto:rcmpersiano@gmail.com>> wrote:

         Even stranger for me, I just get a black window. Looks
         like the right click to see the code that makes the cube
         is going wrong.


     Yes, sometimes I get a black object instead of red. Have you
     View All after the black screen?

     The bug has many manifestations and not always I am
     able to reproduce a specific one. For instance, once I was
     unable to get the right colors back even changing to
     View/Preview. Interestingly, in that case the View/Wireframe
     and View/Surface worked despite the wrong colors. To get rid
     of it I had to restart. 
     _______________________________________________
     OpenSCAD mailing list
     To unsubscribe send an email to
     discuss-leave@lists.openscad.org
     <mailto:discuss-leave@lists.openscad.org>

OpenSCAD mailing list
To unsubscribe send an email to discuss-leave@lists.openscad.org

This Black / Red thingi might be a side effect of the mouse selection, triggered by the right click. The selector is drawing into a separate background buffer. Unfortunately I cannot reproduce this behaviour on master on my machine. The ID of the object is encoded into the color, whereby object 1-255 are encoded in different shades of red, 0 (black) is the background. This might be a bug in the combination of thrown-together/selection, it looks like the framebuffer selection is somehow broken. I will look into this as soon as I can make room in my schedule! On 01/04/2021 15.28, nop head wrote: > To be clear, it isn't a black object filling the preview window, it is > the whole main window pane that goes black. > > On Thu, 1 Apr 2021 at 14:26, nop head <nop.head@gmail.com > <mailto:nop.head@gmail.com>> wrote: > > I haven't got any menus but I can get the view menu with Alt+V but > view all is then Ctrl+Shift+V and that does not work.  I can arrow > down to it and select it but I still have an all black window. > > I think this is a separate bug because I don't need to be in > thrown together mode. Just a right click on the cube with another > Microsoft Mouse that has switch bounce on the right button. It > shows the one line stack trace over an all black window and I > haven't found a way to recover. > > OpenSCAD 2021.03.24.ci7656 on Win7/ 64. > > > On Thu, 1 Apr 2021 at 13:30, Ronaldo Persiano > <rcmpersiano@gmail.com <mailto:rcmpersiano@gmail.com>> wrote: > > Even stranger for me, I just get a black window. Looks > like the right click to see the code that makes the cube > is going wrong. > > > Yes, sometimes I get a black object instead of red. Have you > View All after the black screen? > > The bug has many manifestations and not always I am > able to reproduce a specific one. For instance, once I was > unable to get the right colors back even changing to > View/Preview. Interestingly, in that case the View/Wireframe > and View/Surface worked despite the wrong colors. To get rid > of it I had to restart.  > _______________________________________________ > OpenSCAD mailing list > To unsubscribe send an email to > discuss-leave@lists.openscad.org > <mailto:discuss-leave@lists.openscad.org> > > > _______________________________________________ > OpenSCAD mailing list > To unsubscribe send an email to discuss-leave@lists.openscad.org
M
MichaelAtOz
Thu, Apr 1, 2021 9:58 PM

nophead wrote

To be clear, it isn't a black object filling the preview window, it is the
whole main window pane that goes black.

I'm wondering if it is related to  forum post
http://forum.openscad.org/Problem-with-latest-nightly-build-td32199.html
,  github issue https://github.com/openscad/openscad/issues/3719  ?
There the entire window is showing the background (ie windows behind
OpenSCAD), similarly the menus pop-up.
These are post 2021.01 snapshots, possible that later library versions make
the condition worse?

For me, this right-click bug shows as a black cube, Preview did not fix it,
had to quit.


OpenSCAD Admin - email* me if you need anything,  or if I've done something stupid...

  • on the Forum, click on my MichaelAtOz label, there is a link to email me.

Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above.

--
Sent from: http://forum.openscad.org/

nophead wrote > To be clear, it isn't a black object filling the preview window, it is the > whole main window pane that goes black. I'm wondering if it is related to forum post <http://forum.openscad.org/Problem-with-latest-nightly-build-td32199.html> , github issue <https://github.com/openscad/openscad/issues/3719> ? There the entire window is showing the background (ie windows behind OpenSCAD), similarly the menus pop-up. These are post 2021.01 snapshots, possible that later library versions make the condition worse? For me, this right-click bug shows as a black cube, Preview did not fix it, had to quit. ----- OpenSCAD Admin - email* me if you need anything, or if I've done something stupid... * on the Forum, click on my MichaelAtOz label, there is a link to email me. Unless specifically shown otherwise above, my contribution is in the Public Domain; to the extent possible under law, I have waived all copyright and related or neighbouring rights to this work. Obviously inclusion of works of previous authors is not included in the above. -- Sent from: http://forum.openscad.org/