[OpenSCAD] Inkscape to OpenSCAD converter needs attention

Hugo Jackson hugo at apres.net
Mon Oct 28 22:05:41 EDT 2019


Inkscape is soon to release version 1.0 and as I understand it existing extensions will not work without some modifications. I applied the instructions of the very brief upgrade instructions that are currently available for the upcoming new version to their current beta release and found no joy.

For Mac users this is problematic in that the current Inkscape Mac compatible version (0.92) won’t work on Catalina, and so if you move to Catalina you just won’t be able to use the Inkscape to OpenSCAD converter at all.

I’m hoping there’s some kind generous soul out who knows python who might turn their attention to what I hope is a relatively straightforward refactoring so that this Inkscape extension will work with the new 1.0 version of Inkscape.

I don’t use it a lot, but it’s super handy when I need it.


Here’s the thingiverse link to the most useful current version of this extension….

https://www.thingiverse.com/thing:1065500


More information about the Discuss mailing list