[OpenSCAD] Crash on F6 and missing preview/render window

tangerine0469 stapleton.hosting at gmail.com
Sat Sep 15 18:53:00 EDT 2018


Hi all,

I have a few issues that crept up all of a sudden with my PC running
OpenScad.

This started off randomly when I opened the program after work the other day
after having spent and evening prior working on a project. The app loads the
editor, the console and the code from the selected project but no
render/preview window. Hitting F5 or the option in the menu appears to run
fine in the console but thats as far as it gets. Hitting F6 however stats
the render and gets to approx 475/1000 before the app closes and drops an
error in my event viewer which doesn't show much of anything:

Faulting application name: openscad.exe, version: 0.0.0.0, time stamp:
0x564d2b59
Faulting module name: openscad.exe, version: 0.0.0.0, time stamp: 0x564d2b59
Exception code: 0x40000015
Fault offset: 0x0000000000f9801a
Faulting process id: 0x3258
Faulting application start time: 0x01d44d3fbf0520be
Faulting application path:
C:\Users\John\Downloads\OpenSCAD-2015.03-2-x86-64\openscad-2015.03-2\openscad.exe
Faulting module path:
C:\Users\John\Downloads\OpenSCAD-2015.03-2-x86-64\openscad-2015.03-2\openscad.exe
Report Id: 2a5e9b25-c4a5-4ce5-a059-2940edba4ee2
Faulting package full name: 
Faulting package-relative application ID: 


I have tried the whole uninstall>reboot>install routine many times and even
using the binary, not the installer.  Falling back on my Sysadmin methods I
decided to try and run the app from the CLI as my user and as admin and this
is where I am finally seeing some details that I need some insight on.
Running the app from the CLI I get this after opening a new or existing
project:
GLEW Error: Missing GL version

I know that GL is up to date and my drivers have been both reinstalled and
then updated when the results were the same. Render shows this in the CLI
(the first line is on open of the .scad file, the rest on crash):

GLEW Error: Missing GL version
CGAL error: assertion violation!
Expression : object_list_
File       : ../src/OGL_helper.h
Line       : 571
Explanation:
Refer to the bug-reporting instructions at
http://www.cgal.org/bug_report.html


I tried to open Help>Library Info and get this:

GLEW Error: Missing GL version
terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_M_construct null not valid

Finally I tried to run "openscad.exe --info" and got this and the app failed
to load at all:

C:\Users\John\Downloads\OpenSCAD-2015.03-2-x86-64\openscad-2015.03-2>openscad.exe
--info

C:\Users\John\Downloads\OpenSCAD-2015.03-2-x86-64\openscad-2015.03-2>OpenSCAD
Version: 2015.03-2
System information: Windows 8 (v6.2.0.0) 8 CPUs 15.90 GB RAM
Compiler: GCC "5.2.0" 64bit
Boost version: 1_57
Eigen version: 3.2.5
CGAL version, kernels: 4.5, Cartesian<Gmpq>, Extended_cartesian<Gmpq>, Epeck
OpenCSG version: OpenCSG 1.4.0
Qt version: 5.5.1
QScintilla version: 2.8.4
MingW build: MingW64
GLib version: 2.44.1
Application Path:
C:/Users/John/Downloads/OpenSCAD-2015.03-2-x86-64/openscad-2015.03-2
Documents Path: C:\Users\John\Documents
Resource Path:
C:/Users/John/Downloads/OpenSCAD-2015.03-2-x86-64/openscad-2015.03-2
User Library Path: C:/Users/John/Documents/OpenSCAD/libraries
User Config Path: C:\Users\John\AppData\Local/OpenSCAD
Backup Path: C:/Users/John/Documents/OpenSCAD/backups
OPENSCADPATH: <not set>
OpenSCAD library path:
  C:/Users/John/Documents/OpenSCAD/libraries
 
C:/Users/John/Downloads/OpenSCAD-2015.03-2-x86-64/openscad-2015.03-2\libraries

OPENSCAD_FONT_PATH: <not set>
OpenSCAD font path:


OpenGL Program Validation results:
Validation successful.
GLEW version: 1.12.0
OpenGL Version: 4.5.13539 Compatibility Profile Context 24.20.13017.1009
GL Renderer: Radeon RX 580 Series
GL Vendor: ATI Technologies Inc.
RGBA(8888), depth(24), stencil(8)
GL_ARB_framebuffer_object: yes
GL_EXT_framebuffer_object: yes
GL_EXT_packed_depth_stencil: yes
GL context creator: WGL
PNG generator: lodepng
OS info: Microsoft(TM) Windows(TM) 6 2 9200 0x24bd0e4 amd64
Machine: 8664


Sorry for the long post, my sysadmin work taught me that there is no such
thing as too much information.



--
Sent from: http://forum.openscad.org/



More information about the Discuss mailing list