[OpenSCAD] Light source and default camera position different on command line

nop head nop.head at gmail.com
Thu Sep 6 11:21:27 EDT 2018


Seems like the GUI should be changed to match the command line. The command
line looks towards the first quadrant (x+,y+) the GUI default is towards
the third quadrant (x-, y+) which seems like a mistake.

On 5 September 2018 at 14:16, Marius Kintel <marius at kintel.net> wrote:

> Possibly an oversight.
> The cmd-line output was created primarily for regression testing purposes
> against itself, and the camera and 3D scene management hasn’t received a
> lot of love, as writing this in low-level OpenGL feels wrong and we haven’t
> found time to choose and tinker with an appropriate higher-level framework.
>
>  -Marius
>
>
> > On Sep 5, 2018, at 6:20 AM, nop head <nop.head at gmail.com> wrote:
> >
> > The default camera position is different in the GUI compared with the
> command line. I can move the camera but when viewed from the same place in
> the GUI the lighting is different. It seems to be higher up in the GUI. Why
> are they different?
> >
> > <veroboard.png>
> > <veroboard_gui.png>
> >
> >
> > _______________________________________________
> > OpenSCAD mailing list
> > Discuss at lists.openscad.org
> > http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
>
>
> _______________________________________________
> OpenSCAD mailing list
> Discuss at lists.openscad.org
> http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscad.org/pipermail/discuss_lists.openscad.org/attachments/20180906/0d73a941/attachment.html>


More information about the Discuss mailing list