[OpenSCAD] compiling openscad from source

sean d'epagnier seandepagnier at gmail.com
Mon Oct 8 09:58:38 EDT 2018


> There are Debian/aarch64 builds on the official OBS repo, but I have
> no idea if they work though, as I have no means to test.
>
>    https://build.opensuse.org/package/show/home:t-paul/OpenSCAD
>

I will find out in a few weeks.

>> I have tried with both qt5 and qt4 without success.  With qt5 the build
>> error:
>>
> [...]
>  >
>> /usr/include/GL/glew.h:283:16: note: previous declaration as ‘typedef
>> double
>> GLdouble’
>>   typedef double GLdouble;
>>                  ^
> That is the normal error on systems that do not support Desktop
> OpenGL but only GLES. It might be possible to compile Qt in a way
> that it works with OpenSCAD, but as long as GLES is enabled, this
> will conflict with other code in OpenSCAD.

This system does support Desktop OpenGL.  Most armv7 systems support
desktop opengl, if only in software.

I think with Qt 5 they make an assumption that on armv7 systems, the user
wants GLES, and defines GLdouble to 32bit floats.   This is usually
much faster because of supported hardware acceleration but doesn't help me.

I don't need accelerated graphics to make use of openscad.  I can maybe try
to build qt5 from source and tweak compile flags to fix this.

> In general, QtMultimedia should be available in Qt4 too. I don't
> know what the reason for the build error is. Maybe Qt4 is indeed
> built without the multimedia support or it's not included for some
> other reason. I can't find any mention of a separate package for
> Qt4 (except on old Ubuntu where it's in qt-mobility or so?).
>
> Another possibility is that it still drags in some settings from
> Qt5 builds, so the simplest test would be to ensure a really clean
> build against Qt4.

I built first with qt4 without qt5 installed, when it failed, tried qt5.

I think it's as you found, it's just not built with multimedia support
for qt4 and no package exists, and the library is not there.

Is it possible to build openscad without qtmultimedia support?

>From here, I must try to build qt4 and/or qt5 from source unless there
are any other ideas.  This can take several days since the machine is
usable while compiling. I compile when I'm sleeping so I don't react to errors
until the next day.

Not sure how this will affect a release for armv7 in the future,
maybe it explains why the version in apt is 2014 and so old?

Thanks,
Sean



More information about the Discuss mailing list