[OpenSCAD] Problem with skin()

jltbel at aol.com jltbel at aol.com
Sat Jan 13 18:10:01 EST 2018


I have a larger model where F5 works but F6 fails.  The problem seems to be related to what I'm generating using skin().  Here's a small model that shows the problem:


<quote>


use <scad-utils/transformations.scad>
use <scad-utils/lists.scad>
use <scad-utils/shapes.scad>
use <skin.scad>


airfoil_inch = [ [0.00,0.00], [.031,.084], [.062,.123], [.125,.176], [.250,.243],
                 [.375,.290], [.500,.324], [.625,.349], [.750,.366], [1.00,.375],
                 [1.25,.343], [1.50,.285], [1.75,.208], [2.00,.126], [2.25,0.00] ];
 
scale_factor = 1.82/2.5;
            
airfoil_mm = [ for (i = [0:len(airfoil_inch)-1]) airfoil_inch[i]*25.4 ];
airfoil_mm_scaled = [ for (i = [0:len(airfoil_inch)-1]) scale_factor*airfoil_mm[i] ];


color("red") translate([30,0,0]) skin([
	transform(translation([-25.4,0,0]), airfoil_mm),
	transform(translation([-scale_factor*25.4,0,25.4]), airfoil_mm_scaled)
]);


translate([-35,0,0]) linear_extrude(height = 25.4, center = false, convexity = 10, twist = 0, scale = scale_factor)
  translate([-25.4,0,0]) polygon(points = airfoil_mm);
</quote>




When I turn on Thrown Together, the red airfoil transforms to all "pink".  What I read says this is bad, but I see nothing in the underlying 2D shape that sticks out as a problem.  What am I missing here?  I'm running with OpenSCAD 2015.03-3 on a 10.12.6 Mac.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openscad.org/pipermail/discuss_lists.openscad.org/attachments/20180113/7f128221/attachment-0002.html>


More information about the Discuss mailing list