[OpenSCAD] puzzlecutlib rendering problem & STL export error Current top level object is empty.

Ronaldo rcmpersiano at gmail.com
Fri Jun 3 08:46:23 EDT 2016


FourthDr wrote
> I'll want to do this for both prints Cycl_XrightFrame.stl and
> Cycl_XrleftFrame.stl. Please see attached.

Those two files have problems too. You probably could not puzzlecut them.
Have you tried to fix them with Netfabb or Meshlab? Sketchup was not helpful
this time. I have them fixed using Meshlab AND Netfabb site Torsten linked
above. Both are free.
Cycl_XleftFrame_fixed_ML.stl
<http://forum.openscad.org/file/n17549/Cycl_XleftFrame_fixed_ML.stl>  
Cycl_XrightFrame_Sk_fixed.stl
<http://forum.openscad.org/file/n17549/Cycl_XrightFrame_Sk_fixed.stl>  

> I'm using the default T puzzle piece because naturally the thing won't
> render and I can't clearly see the cuts with the other code. 

A change in the dovetail code could provide a larger peg.

> I've been searching around for something that can fix/repair SLT or the
> original source format that the STL's for the mill came in. Not much luck
> on
> the source files original format.

https://en.wikipedia.org/wiki/STL_%28file_format%29
<https://en.wikipedia.org/wiki/STL_%28file_format%29>  

> Would be neat if OpenSCAD could do that. With the exception of also being
> able to create connectors other than pegs as my printer doesn't handle
> small
> hole/pegs/pins accurately enough for that to work.

OpenSCAD already do that with a simple user code like puzzlecutlib.scad. No
reason to include it in the core. There is nothing fundamentally wrong with
puzzlecutlib.scad. The problems you had came from problematic stl's. For
this, there are tools out there.




--
View this message in context: http://forum.openscad.org/puzzlecutlib-rendering-problem-STL-export-error-Current-top-level-object-is-empty-tp17440p17549.html
Sent from the OpenSCAD mailing list archive at Nabble.com.




More information about the Discuss mailing list