[OpenSCAD] Visually and by inspecting code: surface looks perfect - But: "Object may not be a valid 2-manifold and may need repair"

kaefert at gmail.com kaefert at gmail.com
Mon May 18 12:19:29 EDT 2015


Hi there Marius!

Thanks for your response! Okey, I've actually removed this part as
part of my simplifications of the original design since I thought it
would be unnecessary because this side is never visible because of the
implicit union with the central cylinder. But fixing this doesn't
solve my problem.

I've attached another version where you can't find any magenta
polygons when pressing F12 but still get this error. Any more ideas?

Thanks, Kind regards,
Thomas K.



2015-05-18 17:43 GMT+02:00 Marius Kintel <marius at kintel.net>:
> On May 18, 2015, at 06:51 AM, kaefert at gmail.com wrote:
>
>> Could someone help me? I've tried for a few hours myself but could not
>> find a workaround.
>>
> The inner end of your screwprop isn’t closed properly; you have some reversed polygons.
> If you put an exclamation mark in front of an object, you can render that object alone, e.g.:
>
>   !screwprop(65, mitte_innen_oben/2, 4, 10);
>
> If you then turn on Throwntogether mode (F12), you can see reversed polygons colored magenta.
>
>  -Marius
>
>
> _______________________________________________
> OpenSCAD mailing list
> Discuss at lists.openscad.org
> http://lists.openscad.org/mailman/listinfo/discuss_lists.openscad.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: screwprop_mod_v3.scad
Type: application/x-openscad
Size: 7518 bytes
Desc: not available
URL: <http://lists.openscad.org/pipermail/discuss_lists.openscad.org/attachments/20150518/c1f0afe7/attachment.scad>


More information about the Discuss mailing list